Облачный хостер Amazon Web Services сегодня обновил версии Linux-образов, доступных для установки к качестве программного окружения на его облачных серверах. Новые версии Linux AMI включают в себя поддержку языка программирования R, а также новые версии Apache и PHP.

Linux AMI (Amazon Machine Image) представляют собой поддерживаемые версии образов Linux, созданные Amazon и предназначенные для работы на ее облачном сервисе Elastic Compute Cloud. Они созданы для работы на версиях Amazon EC2 во всех датацентрах компании.

AWS Linux AMI 2012.09 базируется на Linux-ядре 3.2.30 и имеет поддержку языка R версии 2.15, предназначенного для статистического анализа и построения графики. В Amazon говорят, что о поддержке R пользователи AWS просят уже более года. Также обновленные AMI поддерживают различные версии Apache и PHP, созданные для работы в разных комбинациях. По умолчанию здесь предложены Apache 2.2 и PHP 5.3, но также можно выбрать Apache 2.4 и PHP 5.4.

Версия Apache 2.4 была выпущена ранее в этом году и является первым мейджор-обновлением Apache c 2005 года. Значительная часть новшеств 2.4 сосредоточена вокруг работы в нагруженных средах.

Здесь же поддерживаются множественные версии GCC и OpenJDK.


Пользователи AMI версий 2012.03, 2011.09 и 2011.02 могут обновиться до 2012.09 через yum updater или Package Installer.